Kbase P154442: Problem with leading spaces and multiple names in appserviceNameList property
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/02/2010 |
|
Status: Unverified
SYMPTOM(s):
Problem with leading spaces and multiple names in appserviceNameList property
appserviceNameList property in ubroker.properties contains a list of names with leading spaces
Connection to Appservice fails
FACT(s) (Environment):
Defined multiple application service names using Progress Explorer
Windows
BETA
OpenEdge 10.2B1B
CAUSE:
Bug# OE00187229
CAUSE:
When Progress Explorer is used to create multiple application service names for a broker, the names are stored in a comma separated list and are assigned to the property appserviceNameList.
Progress Explorer constructs this list and inserts a space after each comma.
In OpenEdge versions prior to 10.2B, the leading spaces were trimmed at runtime.
In OpenEdge 10.2B, the leading spaces are retained because a space is a valid character. This can cause client connections to fail because the NameServer will not be able to be match the client's requested application service name with its own list of registered application services.
Example: client requests "Accounting" and the NameServer list contains " Accounting".
This problem occurs only when Progress Explorer is used to create a broker with multiple application service names and does not occur when there is a single service name.
FIX:
OpenEdge Explorer does not insert spaces into the comma separated list and can be used to correct the problem.
Start OpenEdge Explorer and configure the affected broker. On the broker tab, click Edit and modify the "Application service names" field and remove the leading spaces after each comma.
FIX:
Upgrade to OpenEdge 10.2B FCS