Kbase P159355: Getting error 8271 when running the wtbman command from a command (cmd) prompt or from a batch file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  29/01/2010 |
|
Status: Unverified
SYMPTOM(s):
Getting error 8271 when running the wtbman command from a command (cmd) prompt or from a batch file
option = unknown or invalid <option name> (8271)
option = unknown or invalid query (8271)
Command being executed from cmd prompt:
wtbman -name nameofwebspeedbroker -query
Command being executed from batch file prompt:
call wtbman -name nameofwebspeedbroker -query
Similar error occurs if using -stop parameter on the same command line instead of -query.
Only this one end user site experiencing the issue.
If the command is changed to:
wtbman -query -name webspeedbroker you receive different errors almost as if the wtbman command is not being understood.
Environment.log from proinventory ran on the failing site shows User and System Level environment variables for DLC, IDLC and IPROMSGS.
Environment.log from proinventory ran on a working site does not have DLC, IDLC or IPROMSGS environment variables set.
If you modify the script or the command line environment on the failing machine to contain the following environment variables, the problem no longer occurs: DLC, PATH and LIB.
set DLC=<directory where Progress is installed>
set PATH=%DLC%\BIN;%PATH%
set LIB=%DLC%\LIB;%LIB%
FACT(s) (Environment):
wtbman command when issued without parameters returns help as expected.
Same command works fine for on other end user sites.
Same script / batch job runs successfully at other sites.
Same command: wtbman -name webspeedbroker -query returns correctly when issued in a proenv window.
Both sites have the same System Environment variable PATH being set.
The PATH environment variable does contain a reference to the %DLC%\bin directory.
AdminServer is running on the default port 20931
AdminServer is alive when the command is failing.
WebSpeed broker is running and servicing users.
Windows
Progress 9.1E
CAUSE:
There is no need to set the DLC, IDLC and IPROMSGS on a System Level.
FIX:
Remove DLC, IDLC and IPROMSGS environment variables from the System Level. This can be done by right clicking on My Computer -> Properties -> Advanced Tab and then select Environment Variables at the end of the screen. Once in this interface, remove or rename the System Level Environment variables mentioned above. All information will now come from the registry.
To prevent this issue from occurring at other sites where Application Providers may not be aware that end users are setting System Environment variables, you can work around the issue by adding the following environment variables to the script / batch file being invoked.
set DLC=<directory where Progress is installed>
set PATH=%DLC%\BIN;%PATH%
set LIB=%DLC%\LIB;%LIB%
When this change is made, the variables being set within the script or batch file will take precedence and the issue will not occur.