Kbase P159183: Cannot start the AdminServer for multiple versions of Progress/OpenEdge on a machine
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/13/2010 |
|
Status: Verified
SYMPTOM(s):
Cannot start the AdminServer for 9.1D as well as 10.1C of OpenEdge
Unable to start the AdminServer via Services
Unable to start the AdminServer via command line.
AdminServer log file showing an exception has occurred.
FACT(s) (Environment):
No anti-virus software installed on the machine.
Multiple NIC cards installed on the machine.
Made changes to the registry for different ports (-port) for each AdminServer process.
Windows Server 2003
Progress 9.1D
OpenEdge 10.1C
OpenEdge Server Technology Category: AdminServer
CHANGE:
Recently installed 10.1C onto the machine.
CAUSE:
Made modification for -port in the registry to accommodate the multiple installations, but did not modify -adminport to something unique for each instance.
FIX:
Use regedit to modify the following registry entries to include -adminport for each version of Progress/OpenEdge being used:
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\(version_of_Progress)\StartupCmd
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\(version_of_Progress)\ShutdownCmd
See solution 18919, "How to change the port the AdminServer is running on to allow more than one AdminServer to run at the same time ?" for additional informaiton on how to modify the registry entries.