Consultor Eletrônico



Kbase P159182: Cannot start the AdminServer for multiple versions of Progress after a system reboot
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   26/01/2010
Status: Unverified

SYMPTOM(s):

Cannot start the AdminServer for 9.1D as well as 10.1C of OpenEdge

Unable to start the AdminServer via Services

Unable to start the AdminServer via command line.

AdminServer log file showing an exception has occurred.

ads0.exp showing failure indicating NoRouteToHost

Problem did not occur until the machine was rebooted.

ipconfig shows a different IP Address than the one returned when using the ping command to ping the hostname of the machine.

FACT(s) (Environment):

hostname command validates to the correct machine name that the AdminServer is attempting to start on.
Can ping the machine name.
ipconfig returns correct IP Address for the machine.
No anti-virus software installed on the machine.
Multiple NIC cards installed on the machine.
Made changes to the registry for different ports (-port) for each AdminServer process.

Windows Server 2003
Progress 9.1D
OpenEdge 10.1C

CHANGE:

Recently installed 10.1C onto the machine.

CHANGE:

Rebooted the machine.

CAUSE:

Wrong IP Address recorded in C:\WINDOWS\system32\drivers\etc\services.

FIX:

Put the correct IP address for the machine into the C:\WINDOWS\system32\drivers\etc\services file.