Kbase P158938: Cannot expand the OpenEdge tree view in OE Explorer due to missing pdh.dll file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/05/2011 |
|
Status: Verified
SYMPTOM(s):
Cannot expand the OpenEdge tree view
Cannot view databases in OE Explorer
Cannot view databases in OpenEdge Explorer
OpenEdge Explorer does not show list of resource
Error building resource table menu in OpenEdge Explorer
Cannot expand the OpenEdge tree view in OE Explorer
Cannot expand the OpenEdge tree view to view the Database resource in OE Explorer.
Admserv.log file shows osmetrics plugin fails to install
Error 7433 in admserv.log file
Failed to install plugin Plugin.System. (7433)
Error 7439 in admserv.log file
Plugin.System not installed: Plugin asked not to be installed. (ADMMsg014) (7439)
java.lang.NullPointerException
The Host Summary screen for the container is showing "null" for all fields ("Hostname, OS version, Progress version, etc) except for the Fathom version field which is correct.
java exception reads:
java.lang.NullPointerException
Message (throw): Error building resource table menu
FACT(s) (Environment):
Osmetrics debugging shows error code
+-> Status returned from PdhEnumObjectItems: -1073738824
Windows Perfmon loads but no system information
Windows
OpenEdge 10.x
OpenEdge 10.2B
OpenEdge Explorer
OpenEdge 10.2A
CAUSE:
The pdh.dll file is missing or corrupted.
If the pdh.dll file is ok, this is an issue with the Microsoft performance counters.
According to Microsoft, the performance counters may be missing or do not contain counter data.
The base set of performance counter libraries may become corrupted and may need to be rebuilt.
Additionally, you may need to rebuild any custom (.NET Framework application created) counters or any extensible counters.
This behavior may occur if certain extensible counters corrupt the registry, or if some Windows Management Instrumentation (WMI)-based programs modify the registry.
FIX:
A workaround is to:
1. Copy in a working pdh.dll file from another system or obtain it from Progress Customer Support.
For a 32-bit installion of OpenEdge on Windows 64-bit the pdh.dll file should be placed in C:\Windows\SysWOW64\
For a 64-bit installation of OpenEdge on Windows 64-bit the pdh.dll file should be placed in C:\Windows\System32\
For a 32-bit installion of OpenEdge on Windows 32-bit the pdh.dll file should be placed in C:\Windows\System32\
2. For 32 bit windows versions (under a commmand prompt opened as administrator) the commands to rebuild the microsoft performance counters are: cd %systemroot%\system32 lodctr /R.
For windows 64 bit the commands are: cd %systemroot%\SysWOW64 lodctr /R
2. If the pdh.dll file is the correct one, it is likely an issue with Windows.
A Microsoft article mention that this could occur on Windows XP if the system is not configured to use a virtual memory paging file. (http://support.microsoft.com/kb/884558)
Another article provides steps to rebuild the performance counters. (This does not apply to Windows XP.)
(http://support.microsoft.com/kb/300956)