Consultor Eletrônico



Kbase P158659: .NET form crashes when run with OpenEdge 10.2B deployment licenses only
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/08/2010
Status: Verified

SYMPTOM(s):

.NET form crashes when run with OpenEdge 10.2B deployment licenses only

Microsoft Windows message box appears containing message "Progress Client has stopped working"

When problem details are displayed in message box, the problem signature is similar to the following:

Problem Event Name: CLR20r3
Problem Signature 01: prowin32.exe
Problem Signature 02: 10.2.2.1235
Problem Signature 03: 4b26bb4e
Problem Signature 04: Progress.clrbridge
Problem Signature 05: 10.2.2.1235
Problem Signature 06: 4b26bb1d
Problem Signature 07: 2d
Problem Signature 08: 1b
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.0.6002.2.2.0.272.7
Locale ID: 1033

Stack trace from PROWIN32 reads:

RaiseException
GetMetaDataInternalInterface
CopyPDBs
LogHelp_LogAssert
C:\Windows\Microsoft.NET\Framework\v2.0.50727\mscorjit.dll

FACT(s) (Environment):

Microsoft .NET Framework 3.0 is installed
Microsoft .NET Framework 3.5 is installed
Same procedure runs correctly in an OpenEdge 10.2A installation with deployment licenses only
Same procedure runs correctly in an OpenEdge 10.2B installation with a development license
OpenEdge 10.2B
Windows

CAUSE:

Bug# OE00194417

CAUSE:

Beginning in OpenEdge 10.2B, Progress.Messages.dll is required at runtime and must be located in %DLC%\bin\dotnet. OpenEdge 10.2B deployment licenses fail to create the %DLC%\bin\dotnet folder and copy the required files to this location.

FIX:

Perform the following actions after installing an OpenEdge 10.2B deployment product:

1) Create a %DLC%\bin\dotnet folder
2) Copy Progress.Messages.dll from %DLC%\dotnet\deploy\signed to %DLC%\bin\dotnet
3) If additional languages are required, copy the appropriate subdirectories from %DLC%\dotnet\deploy\signed to %DLC%\bin\dotnet.