Kbase P158240: Installation of WebSpeed Messenger to existing installation may remove entries for other products fr
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  07/01/2010 |
|
Status: Unverified
SYMPTOM(s):
Installation of WebSpeed Messenger to existing installation may remove entries for other products from ubroker.properties.
Adding products to existing installation breaks other functionality.
Can't start my WSA after adding Webspeed Messenger
Adding Webspeed Messenger broke my WebServices configuration.
FACT(s) (Environment):
Windows
OpenEdge 10.2A
CAUSE:
Bug# OE00194419
CAUSE:
This problem is due to incorrect actions taken by the Progress install code. It should not remove existing sections of the ubroker.properties.
FIX:
One workaround has been found to help in this situation.
1) Shutdown all Progress / OpenEdge processes.
2) Backup the conmgr.properties and ubroker.properties; management.properties (if it exists); ubroker.properties-sav, and the ubroker.properties-saved.
3) Uninstall Progress / OpenEdge
4) Re-Install all products simultaneously to the same installation location.
5) Review the entries from the ubroker.properties-sav and the ubroker.properties-saved. Between these two files find the one which contains all definitions for AppServers or WebSpeed brokers exist. Rename the file to ubroker.properties and put the file in the {DLC}/properties directory.
6) Put the conmgr.properties file and any properties file other than the ubroker.properties* saved from step 1 into the {DLC}/properties directory.