Kbase P158061: WebSpeed agents are all busy which is preventing them from servicing users.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/08/2010 |
|
Status: Verified
SYMPTOM(s):
WebSpeed agents are all busy.
wtbman is showing WebSpeed agents in a BUSY state for a very long period of time.
Users connecting to the database via WebSpeed agents appear to be hanging.
Operating system command: pstack ran against the WebSpeed Agents is showing that these processes are bottlenecking on an Exclusive lock.
pstack output of hung WebSpeed agent process:
semsys
latWaitOnSem
latWait
latXlock
latlatch
vstLockFetch
rmFetchVirtual
WebSpeed log confirms that agents are experiencing a record get lock timeout.
Lock wait timeout of seconds expired (8812)
promon gather script identifies processes are napping on the LHT and LKT
promon gather script showing user process with a large amount of record locks.
FACT(s) (Environment):
Users can access the database outside of WebSpeed without hanging.
Multiple databases are connected at the time when the performance issue is being experienced.
Solaris
OpenEdge 10.2A
CAUSE:
There was code that was released into the Development environment which queried the _Lock table many times. This code resulted in bottlenecks on the latches needed to access the Lock Table.
FIX:
Remove the offending program from the environment. Consider changing the scope of the transaction so as to not lock a large number of records or monopolize the Lock Table.