Consultor Eletrônico



Kbase P157447: WebSpeed Broker connecting to DataServer for Oracle fails to start
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   04/01/2010
Status: Unverified

SYMPTOM(s):

WebSpeed Broker connecting to DataServer for Oracle fails to start

Some Agents fail to start (for example, 2 Agents out of 10) with Oracle-related errors in the server log file

ORACLE error see "ORACLE Error Messages and Codes Manual". (1252)

ORACLE error -1012 see "ORACLE Error Messages and Codes Manual". (1252)

** not logged on

Failed to connect to ORACLE database . (1451)

Oracle sqlnet.log file reports error 12560

Fatal NI connect error 12560, connecting to:
(DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oracleORCL)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))'))(CONNECT_DATA=(SID=ORCL)(CID=(PROGRAM=<DLC>\bin\_progres.exe)(HOST=CONBEBESVC04)(USER=SYSTEM))))
VERSION INFORMATION:
TNS for 32-bit Windows: Version 8.1.7.4.0 - Production
Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 8.1.7.4.0 - Production
Time: DD-MMM-YYYY HH:MM:SS
Tracing not turned on.
Tns error struct:
nr err code: 0
ns main err code: 12560
TNS-12560: TNS:protocol adapter error
ns secondary err code: 0
nt main err code: 530
TNS-00530: Protocol adapter error
nt secondary err code: 2
nt OS err code: 0

Timestamp of sqlnet errors match timestamp for WebSpeed agent failures

FACT(s) (Environment):

Stopping/starting AdminService/WebSpeed via Windows Scheduled Tasks
Failure occurs when restarting WebSpeed
WebSpeed starts as expected when started manually via Progress Explore) after a failure has occurred
WebSpeed agents that do start can be seen querying the Oracle database in dataserv.lg prior to WebSpeed going down
WebSpeed has the following settings:

Initial Number of Agents to Start - 10
Minimum Agents - 10
Maximum Agents -10
Increasing Agent Startup Timeout has no effect
Progress 9.1E
Windows
Oracle 8.x

CAUSE:

The exact cause is unknown at the time of this writing. However, the logs suggest a problem with the Oracle TNS Adapter. Given that the machine is in the process of restarting all services and WebSpeed and the TNS Adapter work together later in the day, a timing issue between WebSpeed and the TNS Adapter is a good candidate.

FIX:

Reduce "Initial Number of Agents to Start" setting until WebSpeed starts as expected. The WebSpeed Broker will start additional agents when required.
Alternatively, create an additional Scheduled Task to add the remaining agents at a later time (i.e. with wtbman -addagents #).