Kbase P157346: AppServer fails to start with port in use message
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/03/2010 |
|
Status: Verified
SYMPTOM(s):
AppServer fails to start with port in use message
Java Process is still active
A _proapsv process is still active
A script is used shutdown all processes as well as to restart all processes.
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge 10.1C04 Service Pack
CAUSE:
Attempt to restart the AppServer while processes are still bound to port 3090.
FIX:
Kill the processes still bound to port "3090" and then reorder the script shutdown process so that the order is the Name Server(s), AppServer(s), Database(s) and then the AdminServer. The NameServer and the AdminServer need not be shut down in most cases. The AppServer(s) should be queried for a not running message before shutting down the databases. If the AppServer(s) are not shutdown in a reasonable time, an asbman -kill can be issued to the AppServer(s) and then queried again to check on their status. If the query still does not get the not running message, alert the DBA, and or Progress. The AdminServer should not be shutdown until all the brokers have been shutdown so that we can query the brokers.