Consultor Eletrônico



Kbase P156979: OpenEdge Replication Agent and Server terminates after connection failure
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   30/06/2010
Status: Unverified

SYMPTOM(s):

OpenEdge Replication Agent terminates after connection failure with the following errors in the source log file:

Connection failure for host <host_name> port <port> transport <transport_name>. (9407)

A communications error <error-code> occurred in function <function-name> while receiving a message. (10492)

A communications error -157 occurred in function rpNLA_PollListener while receiving a message. (10492)


A TCP/IP failure has occurred. The Agent's will enter PRE-TRANSITION, waiting for connection from the Replication Server. (11699)

PROGRESS AppServer network protocol mismatch. (5565)

A communications error <error-code> occurred in function <function-name> while receiving a message. (10492)

A communications error -4010 occurred in function rpNLA_PollListener while receiving a message. (10492)

Unexpected error <error-code> returned to function <function-name>. (10504)

Unexpected error -4010 returned to function rpAGT_AgentLoop. (10504)


A communications error <error-code> occurred in function <function-name> while sending <message-id>. (10491)

A communications error -155 occurred in function rpNLA_SendAgentError while sending AGENTERROR. (10941)

The Fathom Replication Agent is shutting down. (10482)

The Fathom Replication Agent <agent-name> is ending. (10506)

OpenEdge Replication Server terminates after connection failure with the following errors in the source log file:

Connection failure for host <host_name> port <port> transport <transport_name>. (9407)

A communications error <error-number> in <function-name>. (11713)

A communications error -4008 in rpCOM_RecvMsg. (11713)

A communications error <error-code> occurred in function <function-name> while receiving a message. (10492)

A communications error -157 occurred in function rpNLS_PollListener while receiving a message.

The Fathom Replication Server is beginning recovery for agent <agent-name>. (10661)

The Fathom Replication Server is beginning recovery for agent agent1. (10661)


Connecting to Fathom Replication Agent <agentname>. (10842)

Connecting to Fathom Replication Agent agent1. (10842)


The Fathom Replication Agent <agent-name> cannot be contacted by the database broker on host <hostname>, port <port-number>. (10496)

The connection attempt to the Fathom Replication Agent <agentname> failed. (10397)

The connection attempt to the Fathom Replication Agent agent1 failed. (10397)

The Fathom Replication Server was unable to reconnect to agent <agent-name>. Recovery for this agent will not be performed. (10697)

The Fathom Replication Server will shutdown but the source database will remain active. (10698)

The Fathom Replication Server is ending. (10505)

FACT(s) (Environment):

Database Target and replication Server can be restarted without errors.
All Supported Operating Systems
OpenEdge Replication 10.x

CAUSE:

A break in the TCP/IP connection between the OpenEdge Replication server and its agents has occurred.

FIX:

No immediate action is required as long as target database and replication Server can be restarted without errors.
If recurrences happen consider using something like Wireshark to find what is causing the network issue.

Please note that development has also indicated that the error 5565 in the target log does not normally occur, but the handling of the communication error is being performed correctly. As long as replication was successfully restarted, there is nothing in particular to worry about yet because some type of a network "blip" could have caused the problem. If the same problem occurs again please contact Progress technical Support providing both the source and target logs.