Consultor Eletrônico



Kbase P156649: OpenEdge Explorer does not restart after changing the password during initial configuration
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   08/03/2010
Status: Verified

SYMPTOM(s):

OpenEdge Explorer does not restart after changing the password during initial configuration

After installing OE Explorer and changing the password upon first connection to the Management Console, the WebServer is not restarted

OpenEdge Explorer can no longer be started after changing the password in the Management Console and running fathom -stop

OpenEdge Explorer cannot be started with fathom -start after the password is changed

Fathom startup failed. (9661)
Error starting Fathom: Web Server startup failurejava.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_Bind

FACT(s) (Environment):

Windows
OpenEdge 10.2A
OpenEdge 10.2B
OpenEdge 10.1C Service Pack 04
OpenEdge Explorer 10.2A
OpenEdge Explorer 10.2B

CAUSE:

Bug# OE00191120

CAUSE:

This is a known issue. The problem is caused by the Jetty Web Server http/https 'port in use' check only during the initial configuration. netstat -an reveals that the port (9090) is still in use and listening when the failure occurs:
TCP [::]:9090 [::]:0 LISTENING

The 'port in use' check only catches IOExceptions on a new Socket instantiation. The Socket constructor, however, may throw other exceptions such as SecurityException and UnknownHostException. In such a case, the code is thrown out of the 'start WebServer' code and Fathom will not re-start as a result.

FIX:

Workaround:

Re-starting the AdminService allows fathom to be started again using fathom -start from the cmd line (or the shortcut: fathom.bat) in order to open and connect the OpenEdge Explorer console.