Consultor Eletrônico



Kbase P154942: AppServers stuck in SENDING mode due to large number of WebClient sessions losing connection.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   4/2/2010
Status: Verified

SYMPTOM(s):

AppServers stuck in SENDING mode due to large number of WebClient sessions losing connection.

AppServers must be terminated and allowed to re-spawn to handle the situation where they are stuck in SENDING mode.

WebClient application dying when network connectivity is lost briefly.

WebClient session terminates abnormally when network connectivity is lost.

FACT(s) (Environment):

WebClient has client logging enabled.
WebClient using logging level 3 for client logging.
WebClient using logentrytypes 4GLTrace for client logging.
Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

Bug# OE00189602

CAUSE:

When client logging is enabled more information is being sent back and forth from the client to the AppServer / WebSpeed / Database broker.
A situation can arise if connectivity is lost where information the client has gathered has a null value.
This was causing the client to crash since it was not appropriately programmed to handle a null value in these situations.

FIX:

Upgrade to 10.2A03 or 10.2B.