Consultor Eletrônico



Kbase P153374: WebSpeed application hang and errors in broker and admin server log
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/13/2009
Status: Unverified

SYMPTOM(s):

WebSpeed application hang and errors in broker and admin server log


java.net.SocketException:No buffer space available (maximum connections reached?): JVM_Bind

Error appears in admserv.lg, and broker logs

Error occurs randomly

Many more TCP connections observed when the error occurs

FACT(s) (Environment):

Windows
Progress 9.x
OpenEdge 10.x

CAUSE:

TCP resource exhausted, the JVM is not able to bind to port

FIX:

Following two solutions from Microsoft were implemented and the issue is eliminated
http://technet.microsoft.com/en-us/library/cc757512%28WS.10%29.aspx
http://support.microsoft.com/default.aspx/kb/196271