Consultor Eletrônico



Kbase P153080: The OpenEdge installation fails on windows 2008 64 bit platform.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/04/2010
Status: Verified

SYMPTOM(s):

The OpenEdge installation fails on windows 2008 64 bit platform.

The OpenEdge installation exits after running for a minute or two.

The installation log file, oesetup.log, located in the C:\Windows directory shows that the last completed event in the [CompletedEvents] section is: Event4=[MM-DD-YYYY HH:MM:SS] The Setup Utility is extracting archives.

The oesetup.log file shows that the last runtime status listed in the [RuntimeStatus] section is: Progress=18

The oesetup.log file shows that the last result code listed in the [ResponseResult] section is: ResultCode=-1 and ResultDescription=Installation aborted.

Running Microsoft's process monitor utility during an attempted installation shows that setup.exe calls vnstart.exe which then invokes mmc.exe. vnstart.exe then exits and closes files, but mmc.exe continues to run.

The windows Task Manager does not show any setup.exe or vnstart.exe process running after the installation appears to fail.

Checking the properties of the folder containing the copy of the installation media shows the same number of files and sub-folders.

While both the original and the copy of the installation folder show the same size, the size on disk values are different.

FACT(s) (Environment):

The installation is using a copy of the application partner's installation media that was copied over the WAN.
The RuntimeStatus Progress=18 value is equivalent to a progress meter bar measuring completion. In this particular case, the install was 18% of the way through extracting the archives when it failed.
The installation is an application partner installation that installs OpenEdge and the 3rd party application. Running the installation does not require the serial number or control codes be entered.
Windows Server 2008 Standard
OpenEdge 10.1C

CAUSE:

The copy of the installation folder is corrupted. After recopying the folder and rerunning the installation, OpenEdge installed correctly.

FIX:

Verify that all files are copied correctly by checking that all file sizes are correct. If needed, recopy the installation folder and verify that against the original.