Kbase P153196: Database started via Progress Explorer/AdminServer does not start on defined Service Port number
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  24/09/2009 |
|
Status: Unverified
SYMPTOM(s):
Unable to connect remotely to database
** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)
Database is running in multi-user mode.
Database log file shows -S -H -N are not enabled
(4262) Service Name (-S): Not Enabled.
(4261) Host Name (-H): Not Enabled.
(4263) Network Type (-N): Not Enabled.
Port number is being defined in the conmgr.properties file.
Promon -> R&D -> Status Displays -> Servers confirms the broker is using a TCP/IP port
Database is being started remotely via Progress Explorer
Database remains in starting mode
Unable to restart database via Progress Explorer after starting it
Restart via Progress Explorer indicates database is in multi-user mode
dbconfig indicates no issues with database configurations
FACT(s) (Environment):
Other databases are able to be started via Progress Explorer/AdminServer on this same system.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
$DLC/properties/conmgr.properties file is corrupt.
FIX:
Restore a known good copy of the conmgr.properties.
Alternatively, move/remove existing copy and restart the AdminServer. This will create a blank conmgr.properties file. Re-add database resources manually.