Kbase P153161: Error 6179 occurs using DataServer for Microsoft SQL Server when password contains # character
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/09/2009 |
|
Status: Unverified
SYMPTOM(s):
Error 6179 occurs using DataServer for Microsoft SQL Server when password contains # character
Error 6179 occurs after submitting login credentials from the 'User ID and Password' dialog
Could not connect to "<MSS Database>" as user "<user>"
Login was denied because of an authorization error. (6179)
SQL Server logs report error 18456 with state 8
MM/DD/YYYY HH:MM:SS,Logon,Unknown,Login failed for user '<user>'. [CLIENT: ###.###.###.###]
MM/DD/YYYY HH:MM:SS,Logon,Unknown,Error: 18456<c/> Severity: 14<c/> State: 8.
State 8 for error 18456 resolves to 'Password Mismatch'
FACT(s) (Environment):
Using Data Administration > DataServer > MS SQL Server Utilities > Create DataServer Schema
Failure is only occurs with DataServer for Microsoft SQL Server utilities
Same user can successfully login to the MSS database using third-party ODBC utilities
Password for the SQL Server user contains the # character
Logins from DataServer for Microsoft SQL Server succeed once the # character is removed from the password
Progress 9.x
OpenEdge 10.x
Windows
MS SQL Server
CAUSE:
The # character is a special character used for comments when parsing connection strings in any OpenEdge utility, not just for DataServer products. As a result, characters from the first # onwards are thrown away, resulting in an incorrect password being sent to the SQL Server.
FIX:
Option #1
Encapsulate password in quotation marks (this works even in Progress utilities such as 'Create DataServer Schema')
Option #2
Change the password of the SQL Server user, removing the # character