Consultor Eletrônico



Kbase P153139: Oracle error 1012 when connecting from Citrix user session
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   09/03/2010
Status: Unverified

SYMPTOM(s):

Oracle error 1012 when connecting from Citrix user session

ORACLE error -1012 see "ORACLE Error Messages and Codes Manual". (1252)

**Not logged in


"Login failure" message in dataserv.lg file

FACT(s) (Environment):

Connection works when logging in as server admin on the Citrix server
ORACLE_HOME is set in registry
User PATH has %oracle_home%\bin at the very beginning
Registry key on ORACLE_HOME has opened up permissions for all users
tnsnames.ora file has opened up permissions for all users
Oracle DataServer connects to remote Oracle instance via Net8
Using local self service Oracle DataServer
All Supported Operating Systems
Progress 8.x
Progress 9.x
OpenEdge 10.x
Windows

CAUSE:

The exact cause is unknown at the time of this writing

FIX:


Admin user has no issue logging in to Oracle, therefore one can start Oracle data server broker as admin user, each Citrix user would connect to this broker as client.
This way the login is delegated to the broker while broker has no login issues.

Follow these steps to implement configuration change.



Start dataserver broker. Go to Start->programs->OpenEdge->progress explorer, bring it up, right click on localhost -> connect


Once connected, select orabroker1 under Oracle Dataserver, right click -> start


Once orabroker1 is started, modify client?s connection string and add following

-S 4445 -Dsrv svub,1


Retry connection from Citrix sessions.