Kbase P109066: OpenEdge/Fathom AdminServer will not restart due to existance of admsvr.lock
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/05/2011 |
|
Status: Verified
SYMPTOM(s):
Run OpenEdge Explorer and cannot display web page
Errors in admserv.log file
Unable to read the PID number from the adminserver lock file: <lock file name> (11361)
AdminServer lock file exists and process still running. Lock: <lock file name> PID: <process id number> (11363)
Shutting down adminserver, lock file found. (11356)
OpenEdge Management AdminServer does not start
OpenEdge Explorer does not start
Cannot display web page
Unable to connect to Admin Server. Ensure Admin Server is running. (8336)
Messages in the admserv.log file
[AdminServer] The D:\Fathom\config\admsvr.lock file exists
[STDERR] Shutting down AdminServer, lock file found.
Sometimes AdminServer,AppServer or WebSpeed log file showing error 9438 occurring prior to the OpenEdge Explorer being restarted.
CTRL_SHUTDOWN_EVENT console event received. (9438)
FACT(s) (Environment):
AdminServer is started in Services
AdminServer does not start in proenv using proadsv
Proadsv -query says AdminServer is not alive
AdminServer is not running.
Admsrvc.exe is in Task Manager
Java.exe is not found in Task Manager
OpenEdge 10.2B
Fathom Management 3.x
Fathom Management 2.1A
OpenEdge Explorer
All Supported Operating Systems
OpenEdge Management
All Supported Operating Systems
CAUSE:
OpenEdge Management and OpenEdge Explorer are a plugin to the OpenEdge AdminServer. These processes work in unison with the AdminServer when OpenEdge Management or OpenEdge Explorer are being used with an AdminServer. The admsrv.lock file exists in the config subdirectory of the OpenEdge Management installation. This is a lock file which, if present when starting, will not allow the OpenEdge/Fathom Management AdminServer or OpenEdge Explorer process to restart.
This lock file is removed when the AdminServer is shut down properly. If the AdminServer is killed or the system is restarted without stopping the OpenEdge AdminServer first, then this file will remain behind.
FIX:
1. Remove or rename the admsrv.lock file under OEManagementinstall-dir\config\directory.
2. Restart the AdminServer in Services
3. Restart the OpenEdge Explorer tool again and log in.
To prevent this from happening again, on reboot check to make sure the AdminServer comes up, if not delete the lock file and restart it.
A simple UNIX script in the init files or a Windows .bat file can accomplish this.
Note:An enhancement request has been entered for Progress to make sure the admsrv.lock file is removed on a server reboot.
FIX:
Enhancement# OE00206293