Kbase 18559: Randomly, unable to Start or Stop a Database on some machines
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/05/2006 |
|
Status: Unverified
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
Progress 8.x
SYMPTOM(s):
Randomly, the database cannot be started or stopped.
Cannot Find Lock (.lk) file. See EVENT VIEWER. (5780)
Shared memory in use by a process other than PROGRESS. (8872)
Starting database server using ProControl || pccmd || netstart
etstop.
The problem has been seen on different types of machines (COMPAQ, IBM Netfinity, HP)
CAUSE:
Find below a list of a known services which causes the problem with Progress:
- Insight Agent (or BMC Patrol Agent) from COMPAQ.
- Netfinity Agent from IBM.
- Big Brother (third party browser based real-time system & network monitoring tool check http://bb4.com)
FIX:
There are different ways to avoid the problem.
1) If you want both services to be started:
Start the Progress service before the others (Netfinity for IBM or Inside Agent for Compaq). Control Panel - Services - Start first the service for Progress.
You can also do this via a Script if necessary (using pre and post backup scripts in your backup software).
Stop both services and when you have to restart the database, start the Service for Progress before the other services as follows:
This example is for Netfinity Service from IBM
***********************************************
#Beginning of the Example
# Stop both services (with PCCMD or NET STOP)
NET STOP "Netfinity"
NET STOP "Proservice for 8.3A"
#Some manipulation can be performed here (Stop the database, Backup.....)
# When you have to restart the Database, load Proservice before
Netfinity
NET START "Proservice for 8.3A"
NET START "Netfinity.."
.....
#End of the example
******************************************
2) The second solution is to setup the other services as Manual, and put the service for Progress on Automatic.