Consultor Eletrônico



Kbase P151201: Remote 4GL clients cannot connect to a database due to error 1432
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/08/2010
Status: Verified

SYMPTOM(s):

Remote 4GL clients cannot connect to a database due to error 1432

** Could not connect to server for database <DATABASE>, errno <ERRNO>. (1432)

** Could not connect to server for database <DATABASE>, errno 10060. (1432)

net helpmsg 10060 from a Windows command prompt shows:

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

During the time of the connection problem, a UNC drive to the same machine is failing when being accessed from the operating system levels.

FACT(s) (Environment):

promon -> R&D -> Status -> Servers shows that there are slots available on the _mprosrv processes to handle new users.
promon gather script indicates that there isn't a bottleneck within the database.
Can telnet to the machine by IP Address.
Can ping the machine by IP Address.
No pending connections are being seen within promon.
Remote clients already connected to the database are fine.
Can connect via shared memory to the database from the database server machine
Can connect in a client server fashion on the database server machine.
Multiple login brokers started for the database server.
Firewalls are in place on the server machine
Windows
OpenEdge 10.1C
OpenEdge Category: Configuration

CHANGE:

Network card, IP address and other network hardware changes were made on the weekend prior to the failures.

CAUSE:

Hostname DNS (Domain Name Server) issue.

FIX:

Reset the DNS Cache on all machines impacted by the network changes.