Kbase P151109: AppServers fail to start with ERROR: Startup Procedure Failed (8113)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  13/12/2010 |
|
Status: Verified
SYMPTOM(s):
Message from server : <serverMsg> (8113)
Message from server: Startup Procedure Failed (8113)
IOException reading message from server : <IOException_string> (8117)
IOException reading message from server java.io.EOFException: pipe to server broken (8117)
ERROR: cannot start server. (8100)
AppServers started successfully the last time they were started about a week ago.
AppServers that do not have an Agent property defined in the Progress Explorer tool for "Server startup parameters" area able to start successfully.
AppServers that have agents trying to connect to the production database on startup fail to start.
There are no messages in the log file for the database the AppServer agents are trying to connect to that indicate that clients are not able to connect.
For an AppServer that fails to start, the AppServer's broker.log file shows that all the initial instance agent threads were started.
Started server thread: <threadName>. (8101)
For an AppServer that fails to start, the AppServer's server.log file has messages that the agent was unable to attach to shared memory.
Unable to attach shared memory <shmname>, error <n>. (1720)
Unable to attach shared memory Global\sharemem.d.h.avmdata.0, error 0. (1720)
Creating a copy of the sports database, starting a broker with -B 262144, and trying to connect a self serve client also fails with a (1720) error.
Connecting a self serve client to a copy of the sports database started with the same -B 262144 startup parameter also fails with a (1720) error.
Connecting a self serve client to a copy of the sports database started with the same -B 262144 and -shmsegsize 128 startup parameters succeeds.
FACT(s) (Environment):
There are four AppServers defined in the ubroker.properties file.
The database blocksize is 4096.
The database broker is started with -B 262144, which allocates 1 GB to the database buffer pool.
Windows Server 2003 R2 Standard
OpenEdge 10.1B03 Service Pack
OpenEdge Server Technology Category: AppServer
CHANGE:
Windows updates were applied and machine was rebooted.
CAUSE:
The exact cause is unknown at the time of this writing. For some reason, the self serve client is unable to attach to the one large shared memory segment allocated by the broker. In this case, the default segment used if no -shmsegsize is used is 1GB.
FIX:
Add -shmsegsize 128 (or some other value less than 1GB) to the database broker startup parameters, shut down the AppServers, shutdown the databases, restart the databases and then restart the AppServers.