Kbase P151008: Attempting to start the AdminServer and getting error from Java UnsatisfiedLinkError for <DLC direct
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/08/2009 |
|
Status: Unverified
SYMPTOM(s):
Attempting to start the AdminServer and getting error from Java UnsatisfiedLinkError for <DLC directory>\bin\ntjavamain.dll
ntjavamain.dll does not exist in %DLC%\bin
Attempted to re-install MS Java but no ntjavamain.dll created.
Used Process Monitor to monitor AdminServer startup and observed Inoculan Antivirus package scanning Java and OpenEdge related files.
Found file in %DLC%\bin named NTJAVAMAIN.DLL.0.AVB
FACT(s) (Environment):
Windows
Progress 9.x
OpenEdge 10.x
OpenEdge Server Technology Category: AdminServer
CAUSE:
Inoculan Antivirus has quarantined one of the OpenEdge files needed to run the AdminServer.
FIX:
Rename the NTJAVAMAIN.DLL.0.AVB file to ntjavamain.dll.
Configure Inoculan to exclude both the Progress / OpenEdge installation directory as well as any database directories or application code directories related to Progress / OpenEdge.