Consultor Eletrônico



Kbase P150955: SonicMQ1 broker log file filling up with connected / disconnected messages
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   8/12/2009
Status: Unverified

SYMPTOM(s):

SonicMQ1.broker.log file is filling up with messages stating that clients were connected and then disconnected a few seconds later

Client connected : <socketInfo>. (8533)

Client disconnected : <socketInfo>. (8534)

FACT(s) (Environment):

Application code has not changed
Progress 9.1x
OpenEdge 10.x
All Supported Operating Systems

CAUSE:

The SonicMQ1 Adapter instance was configured with "Terse" for the broker and server log files. The application code which used Sonic was coded to constantly connect, process available messages then disconnect. The "Terse" logging level does indeed cause the logging of connections and disconnections. The application code is working as designed and will not be changed to reduce the number of connection/disconnect cycles.

FIX:

Change the logging level for the SonicMQ1 instance (both broker and server) from "Terse" to "Error Only".