Consultor Eletrônico



Kbase P150913: Unable to start the database using ProControl.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/08/2009
Status: Unverified

SYMPTOM(s):

Unable to start the database using ProControl.

Hitting the Start button in ProControl returns a message that the .lk file cannot be found.

Cannot Find Lock (.lk) file. See EVENT VIEWER. (5780)

Viewing the Security properties of the directory where the database is located shows that the user SYSTEM is not included in the list of users that have permissions to write to that directory.

FACT(s) (Environment):

Viewing the Log On properties status for the ProService for 9.1E service in Windows shows that the service is logging on as the Local System Account.
Windows
Progress 8.3E

CAUSE:

The directory where the database is located does not have SYSTEM as a user with write privileges.

FIX:

Add the SYSTEM user to the list of users in the Security tab of the directory's properties and allow write permissions for that user. If the ProService is being started by a user that logs in as the Local System Account, then the directory must include SYSTEM as a user with write permissions to that directory.