Consultor Eletrônico



Kbase P150489: Using a Progress application through XenDesktop results in poor performance
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/08/2009
Status: Unverified

SYMPTOM(s):

Using a Progress application through XenDesktop results in poor performance

Using same Progress application through non Citrix work station results in good performance

Using Symantec Antivirus to perform real-time antivirus monitoring

Symantec set to exclude OpenEdge / Progress installation directory and contents.

Symantec on XenDesktop set with increased, more aggressive antivirus scan settings.

Symantec on XenDesktop set Heuristic searching turned enabled.

Using same Progress application on XenDesktop with Viper antivirus package results in good performance

FACT(s) (Environment):

All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

Extremely aggressive antivirus scanning can have adverse penalties for application performance.
Antivirus packages which use heuristic search patterns to detect new virus activity may intensely scan running applications and slow their functioning.

FIX:

Some attempts must be made to balance safety from virus attacks with application performance.