Kbase P150344: Database log file shows Registry Errors when clients try to connect to the database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/29/2009 |
|
Status: Unverified
SYMPTOM(s):
Error messages are logged in the database logfile
Registry error : Could not add message file '' to the Event Viewer. (5177)
Registry error 5 : Could not add message file 'C:\Progress\OpenEdge\bin\PROMSGS.DLL' to the Event Viewer. (5177)
Previous message sent on behalf of user <nnn>, server pid <nnn>, broker pid <nnn>
FACT(s) (Environment):
Client process is connecting in Client/Server mode to the (remote) database
Windows
Progress 9.x
OpenEdge 10.x
OpenEdge Category: Diagnostics
OpenEdge Category: Configuration
CAUSE:
User account on client machine (Windows) does not have sufficient permissions to write to Registry
FIX:
In the Registry (client's machine) allow Full Access to the user's permissions for the following key:
"MyComputer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\Eventlog\Application\<DATABASE NAME>_PROGRESS"
Note: Substitute <DATABASE NAME> in the Registry key with the real database name