Kbase 18538: Apptivity - Diagnosing 503 Error With HTML Project
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Unverified
FACT(s) (Environment):
Apptivity
SYMPTOM(s):
The following error is reported by the browser when running an Apptivity HTML project;
503 Service Unavailable
No agents are AVAILABLE
This generally occurs when no agents have started.
CAUSE:
This error will occur if the first page request comes before the
agents have started. If there are a number of datasources, the startup time can be significant. In this case, simply reloading the HTML page ("Reload" in Netscape, "Refresh" in IE) should take care of the problem.
FIX:
If the error still occurs, check the HttpServer.log file for errors.
If there are startup errors with the datasources, the agents will
never start.
You can also check the state of the agents with Apptivity Workshop as
follows:
1) Run the project
2) Point your browser to the URL below (entering it all on one line), substituting the project name for "project":
'http://localhost:8080/servlet/project/workshop?testPage=project/Index.html'
3) Select 'Agent Info' under 'WebTools' in the frame on the left
4) Select the 'Agents by Application' button
You will see 'State' listed under 'Agent[project]'.