Kbase P149396: Web Services clients are getting ERROR: No servers available. (8089) when trying to connect to a dat
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  8/4/2009 |
|
Status: Unverified
SYMPTOM(s):
Web Services clients are getting ERROR: No servers available. (8089) when trying to connect to a database.
ERROR: No servers available. (8089)
The (8089) error does not occur immediately after starting the AppServer.
The (8089) error appears after a period of time when, and according to information in the AppServer log files, all of the 12 spawned agents are currently busy.
Running promon during times when clients were getting the (8089) errors showed that there were users holding exclusive locks on records in several key tables that are commonly accessed by many clients.
The exclusive locks being held by clients are in a limbo state, which indicates that the record has been released, but the transaction has not ended yet. As a result, the lock cannot be released until the transaction has ended.
FACT(s) (Environment):
maxSrvrInstance=12 for this particular AppServer, as defined in the ubroker.properties file.
The operating mode of this particular AppServer is state-free.
The controlling NameServer is set to NS1.
Linux
OpenEdge 10.1C03 Service Pack
CAUSE:
Parts of the application are holding exclusive locks longer than expected because the scope of the transactions are larger than what was originally believed.
FIX:
Modify the application program code to narrow the scope of the transaction where locks are acquired so that these locks can be released as quickly as possible.