Kbase P149319: Application that generates estimates hangs on Windows
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  7/9/2009 |
|
Status: Unverified
SYMPTOM(s):
Application that generates estimates hangs on Windows
Application always hangs when generating an estimate at end users site.
Application hangs when one of the end users database is restored and used as application vendor's site.
Hung prowin32.exe process is getting significant amounts of CPU.
Application hang is database specific.
proutil dbname -C dbrpr scans clean on problematic database
proutil dbname -C idxfix found and addressed 6 errors.
Index <index number> (<owner name>.<table name>, <index neme>): Deleted key <key value> recid <record identifier>. (8828)
proutil dbname -C idxcheck scanned clean.
Dump and load of database completed successfully.
Control Break interrupts the client process from the hang.
No errors reported in database log file.
No errors reported in client log file when logginglevel was set to 3 and logentrytypes were set to 4GLTrace,DB.Connects, FileID
FACT(s) (Environment):
Application does not hang when invoked against similar databases at application vendor's site,
Application makes use of 4 databases.
Windows Server 2003
OpenEdge 10.1B03 Service Pack
OpenEdge Category: Database
OpenEdge Database Category: Repair
OpenEdge Category: Language (4GL/ABL)
CAUSE:
The fact that the Control Break was able to interrupt the application from the hang condition indicates the root cause is application specific and not a database corruption issue. Issue was the result of an infinite loop within the application when it encountered a field in the database with a specific value.
FIX:
Use the OpenEdge debugger to debug the 4GL application. Then once inifinite loop is identified, fix it. Add additional code to control data being entered into the field in question that resulted in the infinite loop being triggered.