Kbase P148881: Progress Explorer cannot connect to AdminServer after 10.2A upgrade.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  14/07/2009 |
|
Status: Unverified
SYMPTOM(s):
Progress Explorer cannot connect to AdminServer after 10.2A upgrade.
AdminServer visible in process list.
Port used by AdminServer is bound to java.
proadsv -query gives error: Invalid arguments specified: -q.
proadsv -start gives error: Invalid arguments specified: -start.
OpenEdge installation made to c:\dlc102a\
Fathom having problems issuing commands from command line.
Example of command line:
fathom -update -host localhost -name mycontainername
Example of errors:
ERROR: Argument -name can not contain the reserved character: '' ''
Example of errors:
ERROR: Argument -name must HTTP compliant.
Example of errors:
ERROR: It can not contain spaces or other special characters.
Entries in proadsv.bat; proenv.bat; AdminServerPlugins.properties; JavaTools.properties contain a trailing slash on the definition of the DLC installation directory. Example: c:\dlc102a\
FACT(s) (Environment):
Windows
OpenEdge 10.2x
CHANGE:
Upgraded to 10.2A
CAUSE:
The trailing slash on the install directory causes many of the scripts and properties values to be incorrectly read / parsed / used.
Though the AdminServer attempted to start it was not able to complete its initalization.
FIX:
The simplest correction is to uninstall and re-install OpenEdge.