Kbase P138774: Can't update schema while OpenEdge Replication is active
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/02/2010 |
|
Status: Verified
SYMPTOM(s):
Can't update schema while OpenEdge Replication is active
User updating schema is waiting for a schema lock
Schema is not being applied
Other users are in the database
FACT(s) (Environment):
All Supported Operating Systems
OpenEdge Replication 10.x
OpenEdge 10.x
CAUSE:
The default OpenEdge Replication parameter setting for schema-Lock-Action=wait. This means that a user who is trying to update the schema will wait until all users exit the database. Once all users exit the database, then the user updating the schema can obtain a schema lock.
FIX:
If you require schema updates to be applied without waiting, it is possible to change the default behavior.
Change the schema-Lock-Action parameter to use the Force option within the replication properties file(s). When the force option is set, the agent will attempt to acquire the exclusive schema lock five times. If the fifth attempt fails, the agent disconnects all users from the target and makes another attempt. If the last attempt fails, the server and all agents terminate. This allows the source database to resume normal activity. When schema update activity completes, the server and target can be restarted.
In the [server] section of the properties file(s), set the following parameter:
schema-Lock-Action=force