Kbase P133392: prowin32 crashes when accessing help with IE7 installed
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  6/30/2009 |
|
Status: Unverified
SYMPTOM(s):
prowin32 crashes when accessing help with IE7 installed
Windows Error Report indicates hhctrl.ocx as the faulty module causing prowin32 to terminate.
Error signature is:
AppName: prowin32.exe AppVer: 10.1.2.1292 ModName: hhctrl.ocx
ModVer: 5.2.3790.2744 Offset: 00013368
FACT(s) (Environment):
hhctrl.ocx is used by prowin32 client to access help.
OpenEdge 10.1B
Microsoft Internet Explorer 7
CHANGE:
Windows Internet Explorer 7 was installed after OpenEdge
CAUSE:
OpenEdge 10.1B and earlier releases install a version of PSAPI.DLL that conflicts with the PSAPI.DLL version installed by Internet Explorer 7.
FIX:
To resolve the conflict between the PSAPI.DLL files, try the following steps:Close OpenEdge if you have it open.In Windows, browse to the following file:
%DLC%\bin\system\nt\PSAPI.DLLRename PSAPI.DLL to PSAPI_OLD.DLL.Relaunch OpenEdge client if the help system works now.If the steps above do not solve the problem, then try the following steps:Close OpenEdge if you have it open.In Windows, browse to the following file:
%DLC%\bin\system\nt\PSAPI.DLLRename PSAPI.DLL to PSAPI_OLD.DLL.
In Windows, browse to the following file and copy it:
C:\WINDOWS\system32\PSAPI.DLLPaste the copied PSAPI.DLL file into %DLC%\bin\system\nt\PSAPI.DLLRelaunch OpenEdge client if the help system works now.