Consultor Eletrônico



Kbase P147889: WebClient application intermittently freezes for 5 minutes trying to connect to AppServer
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/19/2009
Status: Unverified

SYMPTOM(s):

WebClient application intermittently hangs for 5 minutes

Network trace shows WebClient is using (outbound) port 2000 when the hang occurs

Applications, not using SCCP, connecting to the host using port 2000 will experience a "hang" situation

Prowin32 clients show same behavior (hang for 5 minutes)

AIA and AppServer logfiles do not show entries for the client request

FACT(s) (Environment):

Applications using a port range starting above port 2000 do not experience the problem
AppServer mode is stateless
Application frequently connects to and disconnects from AppServer using a number of ports
WebClient connects to AppServer broker through WAN (Wide Area Network), Firewall, Loadbalancer, AIA broker
SCCP is using port 2000 (default)
All Supported Operating Systems
OpenEdge 10.x
Progress 8.x
Progress 9.x

CAUSE:

Cisco routers used in the network are by default configured with SCCP (Cisco's Skinny Call Control Protocol) enabled

FIX:

Change router settings as to disable SCCP on port 2000 (or any other port which could be used by applications)