Kbase P105424: Incompatible Last Transaction number Error when opening Fathom Configuration database.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  03/11/2009 |
|
Status: Verified
SYMPTOM(s):
Incompatible Last Transaction number Error when opening Fathom Configuration database.
Error opening Fathom Configuration database <path to db>.(10148)
Incompatible Last Transaction number.
Fathom.odb database is corrupt.
fathom.odx file is not always removed when Fathom database is stopped.
FACT(s) (Environment):
Fathom Management 3.0A
All Supported Operating Systems
Fathom Management 3.0A
CAUSE:
Fathom.odb file became corrupt when the system ran out of disk space. The odx file was not removed when the session crashed and attempts to delete odb database on startup failed. Fathom was unable to restore the automatic backup.
FIX:
Upgrade to Fathom 3.0A01 or later.
Perform the following steps to replace the odb database and to recover jobs and reports so they do not have it be recreated from scratch.
1. Check for a fathom/config/fathom.xml file. If this is missing there is no backup of the Fathom Configuration database and it will have to be recreated from scratch. Taking a backup now is too late. If the file exists continue to step 2.
2. Copy all Jobs, Reports in the fathom/reports directory.
3. Stop the AdminServer.
4. Delete the current odb database.
5. Install Fathom Service Pack 3.0A01 or later.
6. Start AdminServer.
7. Stop the Adminserver
8. Restore Jobs and Reports that were exported in step 2 above.
9. Restore the fathom.xml file