Kbase P147649: Unable to connect to database via JDBC / ODBC after upgrade to OpenEdge 10.1C
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  09/06/2009 |
|
Status: Unverified
SYMPTOM(s):
Unable to connect to database via JDBC / ODBC after upgrade to OpenEdge 10.1C
Attempting to connect to the database via SQLEXP fails with error 8933
Error: <command name | SQL Exception message>. (8933)
Error: [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.. (8933)
Database log file reports error 8841 when the broker attempts to start a SQL server
SQL server process terminated. (8841)
Java Stack trace taken from the SQLExplorer.exceptions file:
java.sql.SQLException
Message (throw): ### Connect stack trace. ###
Message (excp): [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.
Stack Trace:
java.sql.SQLException: [DataDirect][OpenEdge JDBC Driver]OE Broker fails to start SQL server.
at com.ddtek.jdbc.base.BaseExceptions.createException(Unknown Source)
at com.ddtek.jdbc.base.BaseExceptions.getException(Unknown Source)
at com.ddtek.jdbc.openedge.client.OpenEdgeClientLoginRequest.preOpenConnection(Unknown Source)
at com.ddtek.jdbc.openedge.client.OpenEdgeClientLoginRequest.preSubmitRequest(Unknown Source)
at com.ddtek.jdbc.openedge.OpenEdgeImplConnection.open(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.connect(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.setupImplConnection(Unknown Source)
at com.ddtek.jdbc.base.BaseConnection.open(Unknown Source)
at com.ddtek.jdbc.base.BaseDriver.connect(Unknown Source)
at java.sql.DriverManager.getConnection(DriverManager.java:525)
at java.sql.DriverManager.getConnection(DriverManager.java:171)
at com.progress.sql.explorer.SQLConnectServer.call(SQLConnectServer.java:37)
at com.progress.common.rmiregistry.TryIt.run(TryIt.java:186)
Running ldd command against $DLC/bin/_sqlsrv2 returns errors
/openedge101c/bin/_sqlsrv2: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4' not found (required by /openedge101c/bin/_sqlsrv2)
/openedge101c/bin/_sqlsrv2: /usr/lib/libstdc++.so.6: version `CXXABI_1.3' not found
FACT(s) (Environment):
Database is located on a Red Hat Enterprise Linux server
SQL connections worked as expected with the previously installed version of OpenEdge 10 (10.1A)
Database log file contains the following version information:
[YYYY/MM/DD@HH:MM:SS.###+0100] P-#### T-# I BROKER 0: (4234) Progress OpenEdge Release 10.1C build 1343 SP01 on Linux <hostname> 2.4.21-4.ELsmp #1 SMP
LD_LIBRARY_PATH reported in the database log file shows:
[YYYY/MM/DD@HH:MM:SS.###+0100] P-#### T-# I BROKER 1: (-----) Shared Library Path set to LD_LIBRARY_PATH=/usr/java/j2sdk1.4.2_05/jre/lib/i386:...
OpenEdge 10.1C
Red Hat Enterprise Linux 3.0
CHANGE:
Upgraded from OpenEdge 10.1A to OpenEdge 10.1C
CAUSE:
The Linux kernel version found in the database log file shows that OpenEdge 10.1C has been deployed on Red Hat Enterprise Linux 3. This configuration is not supported and not expected to work since OpenEdge 10.1C was compiled on Red Hat Enterprise Linux 4 and has dependencies on it (see ldd results).
In addition, the JVM version is also incorrect; OpenEdge 10.1C requires JVM 1.5 32-bit.
FIX:
Option #1
Upgrade to Red Hat Enterprise Linux AS/ES/WS 4.0 (update 5) or later. Refer to the OpenEdge® 10 Platform & Product Availability Guide for more information on supported platforms.
Option #2
Downgrade the version of OpenEdge to a version supported on Red Hat Enterprise Linux 3 (for example, 10.1B).