Consultor Eletrônico



Kbase P147044: Microsoft Access getting error 7512 when trying to re-open a linked table to a Progress / OpenEdge d
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/28/2009
Status: Unverified

SYMPTOM(s):

Microsoft Access getting error 7512 when trying to re-open a linked table to a Progress / OpenEdge database.

[DataDirect][OpenEdge JDBC Driver][OpenEdge] Access denied (Authorization failed) (7512)

FACT(s) (Environment):

Windows
Progress/OpenEdge Product Family

CAUSE:

The login permissions have not been stored within Access for the linked table.

FIX:

When an ODBC link is made within Microsoft Access, after the data source has been selected and the user login credentials have been submitted and validated, a window is shown of all the tables within the Progress database which can be linked to.
Within the same dialog window is a check box for: Save Password.

This option for Save Password must be enabled for each table that is linked to within Microsoft Access.

If this option is not enabled then the next time the Access Database is opened the link will give error 7512 that Access is Denied because no password was stored within Microsoft to seemlessly reconnect the link.