Kbase 18501: Program Run on V9 AppServer on Windows Platform Cannot Print
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  15/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.x
Windows NT 32 Intel/Windows 2000
Windows XP
SYMPTOM(s):
Failure to Print using the Progress Appserver
RO-ERROR-MESSAGE=Specified printer is not installed or specified port is not available
CAUSE:
The AdminService is logging on to the machine using the "System Account" and therefore does not have the authority to print to the selected printer.
FIX:
Modify the service so that it logs on to the machine using an account that has authority to access the printer(s) that you need to print to.
1) Click the "Start" button in the TaskBar.
2) Select "Settings" from the popup menu. At this point you will get another popup menu.
3) Select "Control Panel" from the popup menu. At this point a window titled "Control Panel" will open up.
3a) On Windows 2000 or XP: Double click on the Administrative Tools icon
4) Double click the "Services" icon. At this point a window titled "Services" will open up.
5) Select "AdminService for PROGRESS 9.x" from the selection list.
6) Click the "Startup..." button. At this point a window titled "Service" will open up.
7) Select the radio button titled "This Account".
8) In the entry field to the right of the above radio button, type in the UserID that you want to login to NT as.
9) Type the password into the "Password" field.
10) Type the password again into the "Confirm Password" field.
11) Click the "OK" button. At this point you can try just stopping and restarting the service however this sometimes will not work. If stopping and restarting the service doesn't work, then close any running applications and reboot the machine.