Kbase P146992: Clients hanging when attempting to add data via an AppServer to a database.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  27/05/2009 |
|
Status: Unverified
SYMPTOM(s):
Clients hanging when attempting to add data via an AppServer to a database.
Clients hang when updating data via an AppServer to a database.
Client screen goes white and never returns when attempting to update or add a record to the database via the AppServers.
Clients can edit data, but they cannot save the changes to the database.
Client processes update an error log table in the database.
Client processes try to clean up an error log table periodically.
FACT(s) (Environment):
Clients can read data without experiencing any issues.
Some tables in the database can be updated without experiencing the problem.
Error log table contains 37 million records / 7 GB in size.
Windows
OpenEdge 10.1B03 Service Pack
OpenEdge Category: Database
OpenEdge Category: Language (4GL/ABL)
CAUSE:
Error log table within the database is not being cleared out periodically as expected by the application.
FIX:
Identify and correct the behavior that is prohibiting the error log table from being cleared out during normal client processing.
A workaround for the issue is to truncate the error log table.