Kbase P124030: Unable to stop the AdminServer on Unix after testing with
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  07/05/2009 |
|
Status: Unverified
SYMPTOM(s):
Unable to stop the AdminServer
proadsv -stop is hanging
proadsv -query returns "AdminServer not alive"
netstat shows java process listening on the AdminServer port
ps -ef showing AdminServer and other ubroker processes like Name Server and AppServer are still running.
Progress Explorer can not connect to the AdminServer
FACT(s) (Environment):
UNIX
Progress 9.x
OpenEdge 10.x
CHANGE:
Installed 10.1C in another directory and have been experimenting (on the same machine where the 9.1E04 AdminServer is running) with starting and stopping 10.1C AdminServer and other ubroker processes like Name Server and AppServers without modifying the ports.
CAUSE:
AdminServer is not working properly due to multiple attempts to start and stop 10.1C processes on ports already in use by the 9.1E04 AdminServer, Name Server and AppServers.
FIX:
1. Kill the java process associated with the AdminServer, Name Server and AppServer processes.
2. Validate with netstat -a that the ports associated with these processes are no longer active.
3. Restart the AdminServer and all other ubroker processes like the Name Server and AppServers etc.