Kbase P111329: The Inactivity Timeout feature of Dynamics does not work
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/09/2009 |
|
Status: Unverified
SYMPTOM(s):
The Inactivity Timeout feature of Dynamics does not work
Dynamics Inactivity Timeout doesn't work
Configured session timeout is never detected
Session keeps running normally after being left idle for longer than the configured session timeout
FACT(s) (Environment):
Progress 9.x
Dynamics 2.1B
OpenEdge 10.x
Dynamics
All Supported Operating Systems
OpenEdge Language Category: ADM
CAUSE:
Bug# OE00124625
CAUSE:
A core limitation prevented the AppServer Activate procedure from sending a message back to the client indicating the reason why it returned an error and aborted the AppServer call. This made it impossible to implement the Inactivity Timeout. See also Solution P79627.
In OpenEdge 10.1B and later releases this core limitation has been lifted, but within the Dynamics framework the Inactivity Timeout feature is still not fully implemented.
FIX:
Workaround:
This workaround requires hat the environment is running on OpenEdge 10.1B or a later release; the existing code only works as expected as long as the core limitation is gone.
Change as_activate.p so that the establishSession call passes True as its 2nd parameter:
RUN establishSession IN gshSessionManager
(INPUT YES, /* Are we activating an already existing session */
INPUT true) /* Should we check inactivity timeouts */
NO-ERROR
This activates the partial implementation of the feature already present in the framework.
This implementation is mostly functional, but not completely. As such there will be some side effects.
Two side effects that have been identified are:
- No-one can now access the AppServer without creating a new Dynamics session.
- The message returned from as_activate.p will not be translated. The standard message dialog uses an AppServer call to get the translation data, and since the session just expired this call will fail.