Kbase P143503: OpenEdge 10.1C installation on Windows 2003 Terminal Server fails to register PROX.DLL
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/31/2009 |
|
Status: Unverified
SYMPTOM(s):
OpenEdge 10.1C installation on Windows 2003 Terminal Server fails to register PROX.DLL
OpenEdge 10.1C installation on Windows 2003 fails to register PROX.DLL
Unsuccessful File Registration
The following file(s) failed to self-register:
C:\Program Files\Common Files\Progress Software\10\prox.dll
Choosing OK on this message will return to the InstallShield and the install continues and completes
Manually registering prox.dll fails with errors
The procedure entry point could not be located in the dynamic link library MSVCR80.DLL.
LoadLibrary("C:\Progress\OpenEdge\101c\bin\prox.dll") failed.
GetLastError returns 0x0000007f.
Starting PROWIN32.EXE fails with an error in MSVCR80.DLL
FACT(s) (Environment):
Reinstalling OpenEdge does not fix the problem
Re-running Microsoft Visual C++ 2005 Redistributable Package (VCREDIST_X86.EXE) installer does not help
Service Pack 2 is installed on the Windows 2003 machine
Installation was run as Local Administrator
Windows machine is a Terminal Server
OpenEdge 10.1C
Windows 2003
CAUSE:
The exact cause is unknown at the time of this writing but it is suggested that the OpenEdge installation was not run in /install mode causing the Microsoft Visual C++ 2005 Redistributable Package not to complete correctly. When re-running VCREDIST_X86.EXE, the installer detected the existing files and terminated without re-installing.
FIX:
From the command prompt, run:
change user /install
Uninstall Microsoft Visual C++ 2005 Redistributable Package
Re-install Microsoft Visual C++ 2005 Redistributable Package (download and re-run VCREDIST_X86.EXE)
Re-register PROX.DLL:
regsvr32 "C:\Program Files\Common Files\Progress Software\10\prox.dll"
Run command:
change user /execute