Kbase P141007: Getting error when attempting test connect to OpenEdge database using ODBC error reads: [DataDirect
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/18/2010 |
|
Status: Unverified
SYMPTOM(s):
Getting error when attempting test connect to OpenEdge database using ODBC error reads: [DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OpenEdge] Server rejects connection on attach
[DataDirect][ODBC Progress OpenEdge Wire Protocol driver][OpenEdge] Server rejects connection on attach
Error attempting ODBC connection to database on customer system yet the same database can be started and connected to on a different system.
Unable to connect to a copy of the empty database on customer system yet the same database can be started and connected to on a different system.
Able to connect to a Probkup/prorest copy of the database on another system
Problem occuring after uninstall and re-install of the OpenEdge software using a customer tailored installation routine.
Unable to connect to any database which has the ISO8859-1 code page.
Test connect from ODBCAD32.exe fails connection and has strange characters at the end of the error message.
FACT(s) (Environment):
Able to connect to copy of the sports database
Able to connect to copy of the sports2000 database
Able to connect to any database that has the Undefined code page.
Customer using Epicor application
Windows
OpenEdge 10.1B
CAUSE:
The pronls.dll is either outdated or corrupt. The copy which failed had a last modified date of 11/3/2006.
One known good copy has a last modified date of 3/5/2007. The pronls.dll with a last
FIX:
Re-Install the OpenEdge installation.
Make sure to apply the most current OpenEdge Service pack.
Check the last modified date of the %DLC%\bin\pronls.dll file to verify the date is at least 3/5/2007.
Test the odbc connectivity again.