Consultor Eletrônico



Kbase P124835: The AppServer fails to start and no errors are written to the log files.
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   31/03/2009
Status: Unverified

SYMPTOM(s):

The AppServer fails to start.

Running the command to query the AppServer returns a message that the AppServer is not running.

Broker: <AppServer name> not running (8313)

The AppServer was starting previously without any problem or error.

There are no error messages written to the AppServer's broker.log or server.log files.

There are no messages at all being written to the AppServer's broker.log or server.log files.

FACT(s) (Environment):

The command used to start the AppServer is: asbman -name <AppServer name> -start.
The command used to query the AppServer is: asbman -name <AppServer name> -query.
IBM AIX
Progress 9.1E

CAUSE:

The file system where log files are being written is full.

FIX:

Free up space in file system or change the location of the log files to a file system that has available space.
The location of the log files is specified in the ubroker.properties file, that can be found in the properties subdirectory of the Progress or OpenEdge installation directory.
Within that file, the AppServer's property section ( [UBroker.AS.<AppServer name>] ) may contain srvrLogFile and brkrLogFile properties that specify the location of the log files. If those properties are listed, then edit them to specify a directory on a file system that has available space. If the properties are not listed, then add them, specifying a files ystem and directory where there is available space.