Consultor Eletrônico



Kbase P143498: Webspeed agents randomly fail to connect to Sonic when using -SMQconnect, get error 12668
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   3/24/2009
Status: Unverified

SYMPTOM(s):

Unable to spawn SonicMQ ClientConnect process. (12668)

Connecting to Sonic Adapter from Webspeed agents

Using SMQDEBUG environment variable to debug jvmstart.exe failure

jvmstart log file shows:

Error accessing stderr redirection file: (\\.\pipe\smqconnect4700)
Error = 2, ErrorMsg = (The system cannot find the file specified.)
Error starting JVM, error 2.
Error = 2, ErrorMsg = (The system cannot find the file specified.)

FACT(s) (Environment):

All Supported Operating Systems
OpenEdge 10.1x
OpenEdge 10.2x

CAUSE:

The Webspeed broker was not configured to enable SonicMQ ServerConnect. ServerConnect is required when using the Sonic Adapter from within Webspeed.

FIX:

Turn the "ServerConnect" option in the Webspeed broker configuration by doing the following:

1) Open Progress Explorer.
2) Connect to your AdminServer.
3) Right click on your Webspeed broker.
4) Select "Properties..." from the popup menu.
5) From the properties dialog box that gets displayed, select "Messaging" from the list on the left.
6) Turn on (check) the "SonicMQ ServerConnect enabled" check box.
7) Click OK to close the properties dialog.
8) Restart your Webspeed broker.