Kbase P142701: Cannot launch Webclient application
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/03/2009 |
|
Status: Unverified
SYMPTOM(s):
Cannot launch Webclient application
WEBCLIENT: Full Access Needed to Application Key in Registry
Unable to install/run Eclipse. You do not have permission to write to the Windows Registry under HKEY_LOCAL_MACHINE\Software\<Vendor Name>\eclipse
FACT(s) (Environment):
Windows Server 2008
Progress 9.1x
OpenEdge 10.1x
CAUSE:
Any user that did not perform the initial install of a WebClient application on a machine, must be given FULL access to the application key in the Windows Registry,
HKLM\Software\Wow6432Node\<Vendor name>\eclipse
in order to update or run the WebClient application. Note that the registry key that needs to be modified is different than the one in the error message.
FIX:
For Windows 2008 the Registry key that needs to be modified has a different path than in other versions of Windows:
HKLM\Software\Wow6432Node\<Vendor name>\eclipse
Edit the permissions on this registry key to allow full control to users and the user will be able to launch the application.