Consultor Eletrônico



Kbase P139148: DBI files not removed after client session terminates gracefully
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/28/2010
Status: Verified

SYMPTOM(s):

DBI files not removed after client session terminates gracefully

gradual accumulation of DBI files in the -T temp directory unnecessarily consuming disk space

The DBI files may not be deleted when the Temporary Directory (-T) client session startup parameter is used.

The DBI files are not deleted at the end of the session when the Temporary Directory (-T) client session startup parameter points to a directory other than the 4GL/ABL session's working directory.

If a -T is specified for the client, and it points to a directory other than the 4GL/ABL session's working directory, the client will leave the session's DBI file in the Temporary Directory specified by the -T client session startup parameter even when the client terminates gracefully.

FACT(s) (Environment):

All Supported Operating Systems
This issue occurs under the following 10.1B03 hot fixes:

OpenEdge 10.1B0333
OpenEdge 10.1B0336
This issue occurs under the following Service Pack:

OpenEdge 10.1C02
This issue does NOT occur under the following service packs:
Progress 9.1E04
OpenEdge 10.1B
OpenEdge 10.1B01
OpenEdge 10.1B02
OpenEdge 10.1B03
OpenEdge 10.1C
OpenEdge 10.1C01
OpenEdge Category: Language (4GL/ABL)

CAUSE:

Bug# OE00176092

CAUSE:

A regression issue as a result of an earlier fix in 10.1B03 Hotfixes to make the DBI filename truly unique. If a -T is specified for the client and this is not the current working directory, the client will leave a DBI file in the specified temp directory once the client terminates gracefully.

FIX:

Apply 10.1C03 Service Pack where this issue has been fixed.

This issue only affects OpenEdge 10.1B03 HOTFIXes 33 and above. Please contact your local technical support.

FIX:

Upgrade to OpenEdge 10.1C03 or later.