Consultor Eletrônico



Kbase P136153: Client hangs during the initiation of an SSL connection
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/10/2009
Status: Verified

SYMPTOM(s):

Client hangs during the initiation of an SSL connection

Program stops running at the point where a SOCKET CONNECT event is received

The use of a network protocol analyzer tool - also known as "packet sniffer" - reveals that some packets of the SSL handshake are lost

Stack trace of hanging process reads: kernel32!RaiseException+0x53
RPCRT4!RpcpRaiseException+0x24
RPCRT4!NdrGetBuffer+0x46
RPCRT4!NdrClientCall2+0x197
hnetcfg!FwOpenDynamicFwPort+0x1d
hnetcfg!IcfOpenDynamicFwPort+0x6a
mswsock!WSPBind+0x2e3
mswsock!WSPSendTo+0x231

FACT(s) (Environment):

Client attempts to establish a SSL connection using the SOCKET CONNECT statement
OpenEdge 10.x
Windows

CAUSE:

Bug# OE00176504

CAUSE:

In one specific case, the hang occurred when the SSL handshake packets sent by the server was lost on the client's network. Progress should recover from this situation and bail out the SSL handshake negotiations after some time. This is the purpose of the change request.

FIX:

As a workaround, troubleshoot the network to determine the cause of the packet loss.Possible causes include: · Heavy network congestion leading to packets collision · Firewall causing some packets to be stopped on an arbitrary fashion · Load Balancing misconfiguration causing two different network paths between client and server one of which is faster, traffic is load balanced and some packets go through the fastest path while others go through the slower one, so for example if packetA comes before packetB but packetB takes the fastest path packetB could get there before packetA and that would be reported as an "Out of order packet" in a network protocol analyzer tool.