Kbase P132340: 4GL clients are no longer able to connect to a database.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/3/2009 |
|
Status: Verified
SYMPTOM(s):
4GL clients are not able to connect to a database.
The primary database broker and watchdog processes have found and removed pending connections according to messages written to the database log file.
Server <server-num> has <num> unresolved pending connections(s). Please check port <port-number>. (12454)
Not all servers have pending connections removed by the broker or watchdog.
Once a server has a pending connection cleared by the broker or watchdog, it never accepts another client connection.
Running promon reveals that an SQL server and a 4GL server are stuck in a deadly embrace.
Running promon with options R&D --> debghb --> 6 --> 15. Buffer Lock Queue shows that the SQL server is holding a buffer lock for DBKEY 1234. ( dbkeys 1234 and 5678 are used for illustrative purposes)
Running promon with options R&D --> 1. Status Displays --> 4. Processes/Clients --> 2. Blocked Clients shows that the SQL server is trying to get a record with DBKEY 5678.
It also shows that the 4GL server is trying to get a buffer lock for DBKEY 1234.
Running promon with options 4. Record Locking Table --> 1. Display all entries shows that the 4GL server has a record with DBKEY 5678 locked in EXCL mode.
As a result, both the SQL server and 4GL server are locked in a deadly embrace, waiting to get access to a resource that the other process has locked. Each process continues to wait since neither is able to get the resource it needs and consequently release the resource it is holding.
FACT(s) (Environment):
The pending connection timeout parameter, -PendConnTime, is currently set to 5.
Both ABL and SQL clients are connected to the database.
HP-UX 11i 64-bit
OpenEdge 10.1A01 64-bit Service Pack
CAUSE:
Bug# OE00136016
CAUSE:
A SQL client accessing a database while performing a table scan in a Type II area can result in a deadlock condition between the SQL client and an 4GL client (or a SQL server, and 4GL client or server). This creates a hang condition on the database.
FIX:
Upgrade to 10.1B01, 10.1C or higher.