Consultor Eletrônico



Kbase P131243: AppServer Agents remain in a STARTING or CONNECTING state for a long period of time before changing
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/03/2009
Status: Unverified

SYMPTOM(s):

AppServer agents remain in a STARTING or CONNECTING state and do not transition to an AVAILABLE state.

(8239), (8245) and (5468) error messages are written to the AppServer log files.

Name Server at Host <Host> Port <Port> is not responsive. (8239)

Application Service <Application Service> not found at NameServer at Host <Host> Port <Port>. (8245)

Application server connect failure. (5468)

FACT(s) (Environment):

IBM AIX POWER 5.3 32-bit
OpenEdge 10.1B02 32-bit Service Pack
A Windows job scheduler, adTempus, is used to schedule and start the processes that use the AppServer to connect to the database.
Several jobs are started, one right after the other, using the Windows adTempus job scheduler.
adTempus is a 3rd party Windows scheduling application available from Arcana Development LLC.

CAUSE:

The exact cause is unknown at the time of this writing.

FIX:

Add a 10 to 15 second pause between job starts. Adding the pause allows all AppServer agents to start and transition quickly to an AVAILABLE state.